Results 1 to 3 of 3

Thread: Fix for Linux Users (No startup after settings dialogue appears)

  1. #1

    Lightbulb Fix for Linux Users (No startup after settings dialogue appears)

    I haven't been able to launch Caves of Qud past the unity settings page for some time since they changed over to using Unity 5+. I finally got annoyed enough today to actually look into what is causing it.

    So Unity by default will have a log file located in:
    ~/.config/unity3d/Freehold Games/CavesOfQud

    If you see something on the lines of:
    "meet the minimum requirements ( <OpenGL 3.2>)"

    ....Then you have the same problem I have - unless you're running some really really archaic hardware you have access to OpenGL 3.2+ and unity isn't picking up on it correctly.

    To get around this issue run the game from terminal with the option "-force-opengl". So in my case:
    ~/.steam/steam/steamapps/common/Caves\ of\ Qud/CoQ.x86_64 -force-opengl

    And boom it should run..
    Note that adding this option to the steam startup parameters for the game still won't let me load it from steam, but at least we can play it eh?

  2. #2
    Thank very much)

  3. #3
    You should be able to set your launch options in steam to include -force-opengl

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •